How to install Windows on Snapdragon 845

  1. Video tutorial by @edi194
    https://www.youtube.com/watch?v=8B2Zc3FULZ4
  2. Video tutorial by @skr-niao
    https://youtu.be/rB3TNrugQLE
4 Likes

什么型号的手机呢?
锤子坚果R1 代号 trident 吗?

Hi,my first post on this forum, already with a problem of booting Win11 image from partition created on Mi 8 (NTFS partition).

I was guided by those three sources :

  1. Original project Renage installation guide:

Renegade Project

Renegade Project

renegade-project.org

BTW Xiaomi Mi 8 is on supported decives list: https://renegade-project.org/#/en/windows/state-frame.html

  1. this yt wideo about installing Win 11 on Mi 8 (unfortunately, in Russian and the youtuber is showing some tips too fast, so I had to slow it down to 0.25 in some parts)

https://youtu.be/HB3nESi-2h4

  1. yt tutorial about installing Win 11 on OnePlus 6T
    https://youtu.be/CaQ9B6IGIjg

So, I have manage to remove and create userdata partition, I have eacreated smaller userdata partion with 30 GB instead of 100-ish something GB,
I have created also \pe partition for WinPE boot (works from UEFI boot), \win (formatted in NTFS) with about 70-something GB, and ESP partition in FAT32.

The UEFI Boot for Mi 8 (device code: dipper) is not installed on the device, I am booting it by flashing it via fastboot (single time, the normal boot image on the device is still genuine boot.img from Xiaomi).

So, just like in the beforementioned guides / tutorials, I am able to boot WinPe (part English, part Chinese), able to start DISM+, able to open prepared Win11 disk (tried either on whole image or n single .wim file) and then:

  1. I am asked for choosing a disk to install Win11;
  2. I choose \win parttion in NTFS
  3. I see window titled ‘Bootmgr Repair-UEFI’ with a message: 'Boot Partition: None Click more to specify it manually
  4. If I choose NTFS partition, I see windwos titled “Tips” with message "If you boot with UEFI, it needs a FAT16/ FAT32 partition
  5. I choose ESP Partition https://www.diskpart.com/articles/efi-system-partition-4348.html, install it, then install drivers; enabling Enable Test-Signing mode and reboot device with shutdown -s -t 0
    After installation I reboot application → no UEFI boot so i go to fastboot mode (by combinatin of buttons) from my PC i flash uefi dipper img i choose pption with Windws Bootloader from UEFI boot option, I am waiting and after a lot of time i see that there was a problem with installation of Windows.

What I am doing wrong here? Any thoughts?