Problem with running windows

Hi there. So I’ve been recently trying to install windows 11 on a oneplus 6t. I followed some tutorials on youtube and managed to get it almost done but in the very last step when I try to launch windows it gives me an error:

Your pc/devide needs to be repaired

The operating system couldn’t be loaded because the digital signature of a file or one of its dependencies couldn’t be verified

File: \windows\system32\driverstore\filerepository\qcpil850.inf_arm64_81f65de2da44293c\qcpil850.sys

Error code: 0xc0000428

You’ll need to use recovery tools. If you don’t have any installation media (like a disc or USB device), contact your PC administrator ot PC/Device manufacturer.

Press the Windows key for UEFI firmware settings.

So, I tried booting and rebooting the system several times but nothing changed. I did the windows installation again but it didn’t work.
Also, I don’t know if that’s a problem but I didn’t retrograde from OOS 11 to OOS 10 (I saw a bit late that I was kind of supposed to do that beforehand). I don’t know either if Android is still on the phone as I can’t access it. It doesn’t matter what I boot, I always end up with this error.

Any ideas?
Thank you in advance ^^

You probably forgot or failed to enable testsigning and nointegritychecks using bcdedit

Oh well it worked. I did it the first time but I guess I mistyped a few caracters.
Anyway ty for the answer. It seems that I can dualboot in the end, but I still haven’t retrograded to OOS 10, is it gonna cause some problems?

No it won’t cause any problem.

Nice thank you. Everything seems to be working fine.
I just have an other question, it seems that I can’t charge the phone while on Windows 11? When I connect it to electric power, windows doesn’t indicate that the battery is charging. I don’t know if that’s a bug or something, because it works fine when I switch to android.